saving . . . saved fatal error in ngspice window has been deleted. fatal error in ngspice window has been hidden .
fatal error in ngspice window
Title
Question
Hi,
I drew a simple schem with an opamp, annotate, erc, checklist, analysis, and kicadtongspice all fine with cir.out and cir.ckt files created.

netlist created:
* EESchema Netlist Version 1.1 (Spice format) creation date: 03/04/2014 17:48:20

* To exclude a component from the Spice Netlist add [Spice_Netlist_Enabled] user FIELD set to: N
* To reorder the component spice node sequence add [Spice_Node_Sequence] user FIELD and define sequence: 2,1,0

*Sheet Name:/
X1 2 3 1 UA741<span class="Apple-tab-span" style="white-space:pre"> </span>
R2 2 1 R<span class="Apple-tab-span" style="white-space:pre"> </span>
R1 2 0 R<span class="Apple-tab-span" style="white-space:pre"> </span>
v1 3 0 SINE<span class="Apple-tab-span" style="white-space:pre"> </span>

.end


I then run the ngspice and get a "fatal error in ngspice" message with the following message:

Note: can't find init file
******
** ngspice-25 : Circuit level simulation program
** The U. C. Berkley CAD Group
** Copyright .......
******
ua741.sub: No such file or directory
Error: .include statement failed.

not sure what has happened here.. help would be appreciated.

Oscad Schematic-Creation-and-Simulation None min None sec 03-04-14, 6:08 p.m. Jmannings118

Answers:

You need to go to subcircuit builder and import the subcircuit of 741 from the subcircuit library. For more details you can refer to the chapter on subcircuit building from the Oscad e-book - <a href="http://www.oscad.in/resource/book/oscad.pdf">http://www.oscad.in/resource/book/oscad.pdf</a>
Once you do this perform netlist conversion.
03-04-14, 7:38 p.m. rakhiwarriar


Hi,
I managed to get rid of the fatal error by referencing the opamp as ic1 instead of x1 and then uncheck the box when netlisting.
but when I run the ngspice, the input and output graphs are not as expected.
This is simple non-inverting opamp config with feedback gain,
so when I put a sine input, the input and output graphs are not the same, just flat lines.
I deleted the opamp and I get, 2 sine graphs where the input and output signals are expected.
so possibly because there is no opamp model being loaded.
<span style="line-height: 1.428571429;">
</span>
<span style="line-height: 1.428571429;">Suggestion:</span>
<span style="line-height: 1.428571429;">If this is the case then you should have some error messages before arriving to this late stage in the simulation.</span>
<span style="line-height: 1.428571429;">I think there should be warning when netlisting or during the kicadtongspice conversion stage to warn the user of the issue!</span>
<span style="line-height: 1.428571429;">
</span>
<span style="line-height: 1.428571429;">So I tried your solution but the cmd gives the following message when I click the subcircuit builder:</span>

Traceback (most recent call last):
File "c:/oscad/oscad/subcktEditor/subcktEditor.py", line 15, in <module>
import selectSubckt
File "c:\oscad\oscad\subcktEditor\selectSubckt.py", line 8, in <module>
import Pmw
ImportError: No module named Pmw

What do I do?

Also having added all the required libs in the beginning and then having the option to add components from the loaded libs, shouldn't that mean there is already a circuit for the opamp I added from the libs,
otherwise I should be going to subcircuit builder for all components including vplot, resistors, capacitors, etc? right??
04-04-14, 10:17 a.m. Jmannings118


Hi,
I have also tried to draw out the inverting opamp circuit in the examples in the oscad.pdf.
But for I get the same issue with my circuit but it seems to work in the examples.
The standard components like opamps, transistors, mosfet, etc.
should be available without having to make any changes same as with <span style="line-height: 1.428571429;">resistors, capacitors, diodes, etc.</span>
04-04-14, 10:50 a.m. Jmannings118


import Pmw
ImportError: No module named Pmw - This issue comes because the Python widget pmw is not installed on your system. https://mail.python.org/pipermail/tutor/2001-September/008470.html
You said that all Python modules are installed, if so this issue should not come. You can cross check if it is installed, to be on the safer side.

If python and other modules are working properly Subcircuit builder should work.

Regarding non inverting amp, there is an example project on the same. This will get you started.

If you want to build one, you can use the 741 IC from the linearSpice library. You have to give its reference as X and not IC1. The spice netlist converter looks for X and makes it a subcircuit. ngpsice complains there is a fatal error because the subcircuit description .sub for 741 was not found. To avoid this, use subcircuit builder and import the definition of 741 from the Oscad subcircuit library. Then .sub will automatically be created.

All standard components are available in the Oscad libraries. The spoken tutorial on schematic creation tells you how to import those libraries.
04-04-14, 2:42 p.m. rakhiwarriar


Hi,
Thanks for the reply.
As I said before all the files on the oscad website has been downloaded and installed through the oscad insaller file...
if programs like pmw and wxpython don't get installed automatically through the oscad installer as they should by default then what can I say..??

I am going to install pmw and revert back... hopefully I complete my circuit without any more issues.
04-04-14, 3:18 p.m. Jmannings118


Well, the issue could be because of the Windows OS that you are using. We have not optimised Oscad installer for Windows 8.1, yet. It works well in Windows XP and Windows 7 in most cases. It works best in Ubuntu Linux OS.
05-04-14, 12:15 a.m. rakhiwarriar


I understand...
<span style="line-height: 1.428571429;">But I only have access to win 8.1 unfortunately and thought I could still get it to work.</span>
At least I got this far and can run other simpler circuits.
Adapting to the situ... is a working progress :-)

Feedback:
Please state that the installation of oscad should be done as admin... otherwise the ngspice doesn't install and would have to be installed after the oscad installation process
05-04-14, 12:46 p.m. Jmannings118


Thanks for trying out Oscad on Win 8.1 and thanks for the feedback.
05-04-14, 2:36 p.m. rakhiwarriar


Log-in to answer to this question.