saving . . . saved Error on using blockMesh command has been deleted. Error on using blockMesh command has been hidden .
Error on using blockMesh command
Hello, I am trying to replicate the cavity problem discussed in Tutorial 3 but have encountered the following error. 
cannot find file "/home/openfoam/run/system/controlDict"

    From function virtual Foam::autoPtr<Foam::ISstream> Foam::fileOperations::uncollatedFileOperation::readStream(Foam::regIOobject&, const Foam::fileName&, const Foam::word&, bool) const
    in file global/fileOperations/uncollatedFileOperation/uncollatedFileOperation.C at line 539.

FOAM exiting

How should I proceed?

OpenFOAM Simulating-flow-in-a-Lid-Driven-Cavity 08-09 min 0-10 sec 27-09-21, 2:51 p.m. entropy101



It looks like you're using an newer version of OpenFOAM while the tutorial you have been referring to is for an older version. The OpenFOAM file/folder structure has changed quite a bit since then. You can find a newer version of the tutorial in the link below.

27-09-21, 3:20 p.m.
Hello Ashley,
Thanks for the response. But even after using the mentioned tutorials on OpenFoam9 I am still getting the same error.

27-09-21, 3:28 p.m. entropy101
Could you please share the screenshot of the terminal with the error message?

27-09-21, 3:30 p.m.
PFA - The requested image.

27-09-21, 3:38 p.m. entropy101
Hi, It looks like you have been trying to execute the command from the run directory. All OpenFOAM commands need to be run from the respective case directory, in this case the cavity directory. You can move into the cavity directory from your current run directory using the command

cd cavity

and then try the OpenFOAM cammands, i.e. blockMesh, icoFoam, paraFoam etc.
27-09-21, 3:41 p.m.
It worked. Thanks for all the help!
27-09-21, 3:43 p.m. entropy101

Login to add comment

Log-in to answer to this question.