saving . . . saved Label bar is missing at content line in HTML block. has been deleted. Label bar is missing at content line in HTML block. has been hidden .
Label bar is missing at content line in HTML block.
 In the new HTML block, the label bar is not visible at the content line. It seems this label bar is not available in most of the places (at the front page, at the HTML block, at the course category description, and so on). please guide me to solve this issue.

Moodle-Learning-Management-System Blocks-in-Admin-Dashboard 04-05 min 30-40 sec 17-05-20, 12:15 p.m. Suman122


What is 'Label bar' exactly?
Do you mean the section title, like HTML block title etc?
Please elaborate.

Also, can you please share a screen shot of the query you are having?
Upload the screen shot to your google drive, enable sharing and share the link here so that we can take a look at the exact problem you are facing.
17-05-20, 2:18 p.m. kashmira.n
17-05-20, 3:05 p.m. Suman122
Not able to access the image .. please enable link sharing .. or else accept the grant access request ..
17-05-20, 3:10 p.m. kashmira.n
 This is the case in all places; at the front page, at the HTML block, at the course category description, and so on. Please let me know how to get this label bar (font size, bold, color, links, etc). 
17-05-20, 3:19 p.m. Suman122
I accepted the access.
17-05-20, 3:27 p.m. Suman122
Yes .. saw it.

Please try purging caches:
- Go to Site administration (last option in the left panel)
- Open up 'Development' tab
- Click on 'Purge caches'
- Here, click on 'Purge all caches' .. this will take some time
- After this completes, logout and login again

Check now whether you are getting the text editor options or not.

Also, please let us know the Moodle version you are using:
- Open up 'Site administration' (last option available on the left panel)
- Open up 'Server' tab
- Here, click on 'Environment' link and please share with us the Moodle version you find here

Please let us know if you have any further queries.

17-05-20, 3:58 p.m. kashmira.n
You can also check if the editors are enabled or not:
- Open up 'Site administration'
- Go to 'Plugins' tab
- Find section 'Text editors' and click on 'Manage editors' link
- Here, check if the editors are enabled or not (eye icon)

Let us know about this.

17-05-20, 4:06 p.m. kashmira.n
Thank you sir. I will let you know after doing it.
17-05-20, 4:07 p.m. Suman122
I have done and checked both the possibilities respectively. The first possibility (clicked on purge all caches) didn't work. I did log out and log in. it was in the same condition. Then, I checked the second possibility and the editors are already enabled (eye icon). So, I didn't change anything. I again checked the text editor options. Surprisingly, three text editor options (prevent automatic linking, insert moodle media, and manage embedded files) are shown. but remaining text editor options are missing. 

Note: When I opened site administration  It is shown (BLOCKS editing off) on the right panel. Shall I do any settings there?

The Moddle version which is found in Environment is 3.8.3 (Build: 20200511)

please let me know further steps to get all the text editor options. 
17-05-20, 5:20 p.m. Suman122

Login to add comment

Please try this:
- Open up Site administration -> Plugins -> Text editors -> Manage editors
- Click on the Up arrow in 'Up/Down' column twice for 'Atto HTML Editor' and bring it to the top
Now, check whether all the text editor options are visible or not.

Also, please enable php opcache, as it is showing up in your server environment screenshot with 'Check' status.
Some helpful links on how to do this:

Also, please send the entire server environment page so that I can take a look at it.
- Site administration -> Server -> Environment
You can do so by right clicking on that page and printing it, this will save the entire page.

Also, nothing to be done for blocks editing option, it comes up whenever your edit mode is on, you can turn it off by clicking on the 'Blocks editing off' button as seen in the image.

Let me know if you have any further questions and also, how this works out.

17-05-20, 8:39 p.m. kashmira.n
Dear sir

After doing this (Click on the Up arrow in 'Up/Down' column for 'Atto HTML Editor' and bring it to the top), I lost all the text editor options. Now it is invisible like the earlier one (lost those three text editor options). 

please find the attachment (entire server environment page in pdf file) in your mail. 
18-05-20, 10:03 a.m. Suman122
Please try purging caches once again and check.

Let me know how this goes.
18-05-20, 10:31 a.m. kashmira.n
I have just now tried it (Purge all caches). After this, log out and log in again. I checked ...... It is the same as the earlier one. No text editor options.  

18-05-20, 10:38 a.m. Suman122
Please give this a try:

Let me know if you have any issues/doubts executing this.

18-05-20, 10:54 a.m. kashmira.n
Also, you can bring 'TinyMCE HTML editor' (for which you were able to get some of the text editing options) back to top by clicking the the up arrow in 'Up/Down' column for this editor at
- Site administration -> Plugins -> Text editors -> Manage editors

Check whether the above post helps with any of these editors.

18-05-20, 12:40 p.m. kashmira.n

I tried these two options given: Go to the area for config of the editor:

First one: Site Admin - Plugins - Text Editors Atto - Atto Tool Bar Settings- (I did the ['default' settings shown below the box, copy to clipboard, then replace all the text] in the dialog box). Then I saved the changes- Purge Caches (log out and log in). I checked it. Still, text editor options are not shown.  

Second one: direct with URL


when I tried this one, it was displayed ( This site can't be reached... yoursite's server IP address could not be found)

18-05-20, 12:48 p.m. Suman122

Login to add comment

Finally, I got when i installed a plugin Font family maintained by Projectes TAC Dept.
20-05-20, 2:29 p.m. Suman122
So, you were able to use/display Atto Editor or TinyMCE or both?
22-05-20, 8:57 p.m. kashmira.n
Also, there are scheduled tasks that run at certain times in Moodle.
So, the changes you make take effect only after some related tasks/cron jobs finish their run.
Need to check for this as well.

22-05-20, 9:03 p.m. kashmira.n
So, you are now getting all the editor options?

22-05-20, 9:05 p.m. kashmira.n
 Now, everything is in the right place. yes, I am successfully getting all the editor options in all required places.
24-05-20, 9:15 a.m. Suman122

Login to add comment

Log-in to answer to this question.