saving . . . saved error opening schematic editor has been deleted. error opening schematic editor has been hidden .
error opening schematic editor
Title
Question
I have installed Kicad and python too but when I open Oscad I get the tool window but I do not get the schematic editor window but instead the following message. The environment variables are also set correctly and Kicad is installed right.
"EESCHEMA IS NOT RECOGNISED AS AN INTERNAL OR EXTERNAL COMMAND, OPERABLE PROGRAM OR BATCH FILE"
i saw a similar post here and tried re-installing kicad and its right. But when I try to follow a similar procedure for Ngspice, it did not open and I got a message saying "Can't open init file" . What could be the problem?




Oscad Schematic-Creation-and-Simulation None min None sec 13-03-14, 1:15 p.m. swethakannan

Answers:

Hello Swetha,

I am assuming kicad is working fine. The only problem is with ngspice.

Please send us the screen shot of the error you are getting.

Thanks



13-03-14, 5:08 p.m. fahim


Hello Swetha

KiCad is not installed properly in your system. Please see item no. 3 under FAQs. <a href="http://www.oscad.in/node/11">http://www.oscad.in/node/11</a>, to re-install KiCad and set the PATH.
One solution to the ngspice problem is to copy the folder "spice" (currently in C:\oscad) to C:\. Then set the PATH of spice to C:\spice\bin.
To set PATH, go to My Computer >> Properties >> Advanced Settings >> Environment Variables >> System Variables >> PATH

Let us know if this works.
Rakhi
14-03-14, 6:15 p.m. rakhiwarriar


Yeah the problem had been with Kicad. While installing it I had set the path as C:\ but this time I set it as C:\Kicad and it worked.
Thankyou sir!
14-03-14, 10:22 p.m. swethakannan


Log-in to answer to this question.