saving . . . saved Error in Confirm path has been deleted. Error in Confirm path has been hidden .
Error in Confirm path
I have a question about the installation of Moodle in Linux.

I did all things which are given in tutorial but got an error in the localhost/moodle.
I select a language then for confirming path, I got error " Parent directory (/var/www) is not writeable. Data directory (/var/www/moodledata) cannot be created by the installer".

How can I solve it?


Moodle-Learning-Management-System Course-Administration-in-Moodle 11-12 min 30-40 sec 12-04-20, 5:13 p.m. prem1914


You can manually create moodledata folder:
mkdir /var/www/moodledata 
chmod 0777 /var/www/moodledata

or give write permission to /var/www folder temporarily:
chmod 0777 /var/www/
and then reset it to 755

Check out official Moodle doc:
12-04-20, 8:51 p.m. kashmira.n
Thanks, sir/madam
I am doing same as you tell but the problem I got '' chmod: changing permissions of '/var/www/': Operation not permitted"
Do you have any idea?
I check the moodle site that you sent me.
But not getting solution
12-04-20, 10:33 p.m. prem1914

Login to add comment

Try this:
sudo chmod 0777 /var/www/

12-04-20, 10:38 p.m. kashmira.n
I create folder moodledata, now the problem "Data directory (/var/www/moodledata) cannot be created by the installer."
how can I solve it?
12-04-20, 11:04 p.m. prem1914

Login to add comment

Delete the manually created 'moodledata' folder once and they try again please.
The above command worked, right?

Let me know if u have any further doubts.
12-04-20, 11:15 p.m. kashmira.n
I delete manually and try this command 'sudo chmod 0777 /var/www/'
and create folder 'moodledata.
but the same error I got again 'Data directory (/var/www/moodledata) cannot be created by the installer.'
12-04-20, 11:34 p.m. prem1914
12-04-20, 11:44 p.m. prem1914

Login to add comment

No .. please dont create the 'moodledata' folder manually.
Please delete the folder and retry it.

Also, please attach a screenshot of the error here.
12-04-20, 11:42 p.m. kashmira.n
Thank you so much sir
I delete moodledata folder and go to next step
all this now goes good thanks sir

I will again contact if I have doubt.
12-04-20, 11:47 p.m. prem1914

Login to add comment

 For database setting I got following error.

Error: Database connection failed

It is possible that the database is overloaded or otherwise not running properly.

The site administrator should also check that the database details have been correctly specified in config.php

Warning: mysqli::__construct(): (HY000/1045): Access denied for user 'moodle'@'localhost' (using password: YES) in /var/www/html/moodle/lib/dml/mysqli_native_moodle_database.php on line 79

Please send me proper path.
12-04-20, 11:59 p.m. prem1914

Do you correctly remember the password?

If not, then try logging into mysql as a 'root' user and then either you can reset the password for the user 'moodle' and retry granting proper permissions to user 'moodle'.

You can run the command "CREATE DATABASE moodle DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci;" only after logging into mysql.

Also, are you using phpmyadmin? If not, they you can try that, it has an easy to use interface.
14-04-20, 12:52 p.m. kashmira.n

Log-in to answer to this question.