saving . . . saved Simulating 555 based astable multivibrator has been deleted. Simulating 555 based astable multivibrator has been hidden .
Simulating 555 based astable multivibrator
Title
Question
Hello Madam/Sir
Am getting run time error while simulating 555 based astable multivibrator. Have tried best, am not able to resolve the error. Have verified the simple ckt simulation in LT Spice, and apparently it works. Please do help in resolving the doubt. Am attaching herewith in-line the .out file

* c:\\users\\prasad.joshi\\esim-workspace\\astable555\\astable555.cir


.include lm555n.sub

* u2 net-_c1-pad1_ ic

.ic v(net-_c1-pad1_)=0

x1 gnd net-_c1-pad1_ net-_r3-pad1_ net-_r1-pad1_ net-_c2-pad1_ net-_c1-pad1_ net-_r1-pad2_ net-_r1-pad1_ lm555n

r2 net-_r1-pad2_ net-_c1-pad1_ 10k

r1 net-_r1-pad1_ net-_r1-pad2_ 1k

c1 net-_c1-pad1_ gnd 1u

c2 net-_c2-pad1_ gnd 0.01u

r3 net-_r3-pad1_ gnd 1k

* u1 net-_r3-pad1_ plot_v1

v1 net-_r1-pad1_ gnd dc 5

* u2 net-_c1-pad1_ ic

.tran 5e-03 4e-03 0e-00


* Control Statements

.control

run

print allv > plot_data_v.txt

print alli > plot_data_i.txt

plot v(net-_r3-pad1_)

.endc

.end




error reported is:

doAnalyses: iteration limit reached


run simulation(s) aborted

Error(parse.c--checkvalid): net: no such vector.

Error(parse.c--checkvalid): a.x1.a3#branch_1_0: no such vector.

Error: bad v() syntax

ngspice 1 ->

Interrupted once . . .

Warning: clearing control structures

ngspice 1 ->



Thanks indeed

regards


eSim Simulating-an-Astable-Multivibrator 00-01 min 0-10 sec 19-11-19, 11:38 a.m. prasadjoshee

Answers:

1. Your step time(5e^-3) is greater than your stop time(4e^-3).
2. Your username prasad.joshi on your computer has a special character "."

Increase your stop time or decrease the step time significantly.
and see if you can save the project in some other directory, perhaps C/: drive itself
19-11-19, 11:48 a.m. Saurabhb17


Thanks a million for the prompt response....
however
1) stop time less than step time was an unfortunate oversight !!! Its 4sec ! Made the change still same error.
2) Username having a special character could be issue, but then other simulation programs with same environment variables are working fine !!
3) shall still try to change the directory and try again !!

Sorry but not able to resolve logically.
please address if possible
thanks indeed for the inputs.

regards
19-11-19, 1:38 p.m. prasadjoshee



Change C1's value to 100p
and C2's value to 0.01u

Make step time=50e-09, stop time=5e-06

Add a global label at the place where you have added a plot_v

Redo the necessary steps and this will work
20-11-19, 9:02 a.m. Saurabhb17


Log-in to answer to this question.