saving . . . saved python workshop has been deleted. python workshop has been hidden .
python workshop
Title
Question
Microsoft Windows [Version 10.0.10240]
(c) 2015 Microsoft Corporation. All rights reserved.

C:\\Users\\Admin>ipython3
Python 3.7.3 (v3.7.3:ef4ec6ed12, Mar 25 2019, 21:26:53) [MSC v.1916 32 bit (Intel)]
Type 'copyright', 'credits' or 'license' for more information
IPython 7.5.0 -- An enhanced Interactive Python. Type '?' for help.

In [1]: numpy, matplotlib
---------------------------------------------------------------------------
NameError Traceback (most recent call last)
<ipython-input-1-78cad429aec3> in <module>
----> 1 numpy, matplotlib

NameError: name 'numpy' is not defined

In [2]: import numpy

In [3]: import matplotlib
---------------------------------------------------------------------------
ImportError Traceback (most recent call last)
<ipython-input-3-0484cd13f94d> in <module>
----> 1 import matplotlib

c:\\users\\admin\\appdata\\local\\programs\\python\\python37-32\\lib\\site-packages\\matplotlib\\__init__.py in <module>
198
199
--> 200 _check_versions()
201
202

c:\\users\\admin\\appdata\\local\\programs\\python\\python37-32\\lib\\site-packages\\matplotlib\\__init__.py in _check_versions()
192 ("pyparsing", "2.0.1"),
193 ]:
--> 194 module = importlib.import_module(modname)
195 if LooseVersion(module.__version__) < minver:
196 raise ImportError("Matplotlib requires {}>={}; you have {}"

c:\\users\\admin\\appdata\\local\\programs\\python\\python37-32\\lib\\importlib\\__init__.py in import_module(name, package)
125 break
126 level += 1
--> 127 return _bootstrap._gcd_import(name[level:], package, level)
128
129

ImportError: DLL load failed: The specified module could not be found.

In [4]: import numpy, matplotlib
---------------------------------------------------------------------------
ImportError Traceback (most recent call last)
<ipython-input-4-1ba94c9f5666> in <module>
----> 1 import numpy, matplotlib

c:\\users\\admin\\appdata\\local\\programs\\python\\python37-32\\lib\\site-packages\\matplotlib\\__init__.py in <module>
198
199
--> 200 _check_versions()
201
202

c:\\users\\admin\\appdata\\local\\programs\\python\\python37-32\\lib\\site-packages\\matplotlib\\__init__.py in _check_versions()
192 ("pyparsing", "2.0.1"),
193 ]:
--> 194 module = importlib.import_module(modname)
195 if LooseVersion(module.__version__) < minver:
196 raise ImportError("Matplotlib requires {}>={}; you have {}"

c:\\users\\admin\\appdata\\local\\programs\\python\\python37-32\\lib\\importlib\\__init__.py in import_module(name, package)
125 break
126 level += 1
--> 127 return _bootstrap._gcd_import(name[level:], package, level)
128
129

ImportError: DLL load failed: The specified module could not be found.

In [5]: import numpy

Python-3.4.3 Using-plot-command-interactively 01-02 min 20-30 sec 21-06-19, 3:22 p.m. Reyana_1985

Answers:

Installing the Visual C++ Redistributable for Visual Studio 2015 from the link given below may solve the problem.

https://www.microsoft.com/en-US/download/details.aspx?id=48145

Please let us know if you face any problem.

Thanks.
21-06-19, 4:41 p.m. iakashchavan


Log-in to answer to this question.