saving . . . saved Getting error when simulating has been deleted. Getting error when simulating has been hidden .
Getting error when simulating
Title
Question
******
** ngspice-26 : Circuit level simulation program
** The U. C. Berkeley CAD Group
** Copyright 1985-1994, Regents of the University of California.
** Please get your ngspice manual from http://ngspice.sourceforge.net/docs.html
** Please file your bug-reports at http://ngspice.sourceforge.net/bugrep.html
** Creation Date: Jan 23 2014 21:34:16
******

Circuit: * c:\\users\\elcot\\esim-workspace\\fossee\\fossee.cir

Error on line 14 : d1 0 net-_d1-pad2_ q2n2907a
incorrect model type
Error on line 15 : 32mhz1 net-_32mhz1-pad1_ net-_32mhz1-pad2_ crystal
unknown device type - error
Doing analysis at TEMP = 27.000000 and TNOM = 27.000000


Initial Transient Solution
--------------------------

Node Voltage
---- -------
vcc 6.36538e-015
net-_32mhz1-pad2_ 6.36538e-015
net-_q1-pad2_ 6.36538e-015
net-_c3-pad1_ -2.91033e-033
net-_32mhz1-pad1_ 6.36538e-015
net-_d1-pad2_ 6.36538e-015



No. of Data Rows : 59
Error(parse.c--checkvalid): alli: no such vector.
ngspice 1 ->

eSim Schematic-Creation-and-Simulation 09-10 min 0-10 sec 16-03-19, 11:39 a.m. Marmitechap

Answers:

//Error on line 14 : d1 0 net-_d1-pad2_ q2n2907a
incorrect model type//
This line indicates that you have selected a transistor spice model(.lib file) instead of a diode spice model, during the kicadtongspice conversion process. As for the crystal you're using, select a pulse source from eSim_Sources library, and set it to 32MHz frequency, as crystals aren't recognized in eSim for simulation.
16-03-19, 7:57 p.m. saurabhbansode@gmail.com


Log-in to answer to this question.